Keil 编译器版本问题

昨天新装了个MDK5.26,在编译原来的工程的时候总是报错。在”Options for Target ‘XXX'”中,”Target” 栏目下,”Code Generation”选择的时候有一定的要求。

1,原来的MDK版本5.15,使用的V5编译器;新的MDK5.26使用的是V6编译器;

2,在5.26版本下,ARM Compiler选择V5.06 update 6(build 750)时候,需要将“Run-Time Environment”中的不必要引用去掉,不然会有大量报错;

3,如果ARM Compiler选择使用“Use default compiler version 6”会自动勾选部分引用,但是由于使用的“CMSIS”版本是旧的,在V6下无法编译通过,编译失败。

4,从V6切换到V5后,记得去掉部分自动引用的库。Keil 编译器版本问题

打赏
原文链接:,转发请注明来源!
STM

发表评论